@lyno/lib-jitsi-meet

JS library for accessing Jitsi server side deployments

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
@lyno/lib-jitsi-meet
1622.6726.29 months ago3 years agoMinified + gzip package size for @lyno/lib-jitsi-meet in KB

Readme

Jitsi Meet API library (with import & TypeScript support)
You can use Jitsi Meet API to create Jitsi Meet video conferences with a custom GUI.
Changes to the original repo:
  • export unbundled code
  • TypeScript support
  • published to npm
  • updated dependencies

Installation

yarn add @lyno/lib-jitsi-meet

Usage

import JitsiMeetJS from '@lyno/lib-jitsi-meet';

JitsiMeetJS.init(initOptions);
const connection = new JitsiMeetJS.JitsiConnection(null, token, options);

Alternative useage

We also provide a prebundled version with jQuery bundled in.
import `@lyno/lib-jitsi-meet/lib-jitsi-meet.min.js`

Building the sources

NOTE: you need Node.js >= 12 and npm >= 6
To build the library, just type:
yarn install
yarn build

Release

yarn release