@mrhenry/babel-plugin-core-web

browser feature polyfills as a babel plugin

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
@mrhenry/babel-plugin-core-web
3811.0.04 days ago4 years agoMinified + gzip package size for @mrhenry/babel-plugin-core-web in KB

Readme

@mrhenry/babel-plugin-core-web
Babel plugin that polyfills browser features.
Bringing polyfill.io to your babel flow.

version Build BrowserStack Status CodeQL

why

Maintaining a correct but minimal polyfill bundle from polyfill.io is a manual process and prone to errors. Babel however knows which features you actually used and the environment you are targeting. Bringing the two together works for us, we hope it does for you too.

install

npm install --save-dev @mrhenry/babel-plugin-core-web

yarn add --dev @mrhenry/babel-plugin-core-web

babel.config.js

module.exports = function(api) {
	/*
		Optionally cache the babel config
		https://babeljs.io/docs/en/config-files#apicache
	*/
	api.cache(true);

	return {
		plugins: [
			["@mrhenry/core-web", {
				browsers: {
					chrome: "31",
					firefox: "26",
					edge: "12",
					opera: "26",
					safari: "8",
					ie: "11",
				}
			}]
		]
	};
};

module.exports = function(api) {
	/*
		Optionally cache the babel config
		https://babeljs.io/docs/en/config-files#apicache
	*/
	api.cache(true);

	return {
		plugins: [
			// Use browserslist default :
			["@mrhenry/core-web"]
		]
	};
};

module.exports = function(api) {
	/*
		Optionally cache the babel config
		https://babeljs.io/docs/en/config-files#apicache
	*/
	api.cache(true);

	return {
		plugins: [
			// A custom browserslist config :
			["@mrhenry/core-web", {
				browserslist: [
					"last 2 versions",
					">0.5%"
				]
			}]
		]
	};
};

webpack config

const babelPresetEnv = require( '@babel/preset-env' );

...

{
	loader: 'babel-loader',
	options: {
		comments: false,
		plugins: [
			[
				'@mrhenry/core-web',
				{
					browsers: {
						chrome: "63",
						firefox: "57",
						edge: "18",
						opera: "57",
						safari: "12",
						ie: "11",
					},
				},
			],
		],
		presets: [
			[
				babelPresetEnv,
				{
					corejs: '^3.6.3',
					targets: {
						browsers: ...,
					},
					useBuiltIns: 'usage',
					exclude: [
						"web.dom-collections.iterator",
						"web.dom-collections.for-each",
					],
				},
			],
		],
	},
}

Example with script tags (module vs nomodules)

example migration

issues

If have any trouble using @mrhenry/babel-plugin-core-web please open an issue here. We will try to get back to you as soon as possible.

missing polyfills

If a polyfill is missing from this plugin please open an issue here.
We do take the specification status into consideration before adding new polyfills.