@ungap/essential-map

An essential Map poorlyfill for legacy browsers.

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
@ungap/essential-map
400.3.22 years ago4 years agoMinified + gzip package size for @ungap/essential-map in KB

Readme

Essential Map
Build Status Coverage Status Greenkeeper badge WebReflection status
An essential Map poorlyfill for legacy browsers.
Only methods are delete, forEach, get, has, and set.
CDN via https://unpkg.com/@ungap/essential-map ESM via import Map from '@ungap/essential-map' CJS via const Map = require('@ungap/essential-map')
Compatible down to IE9, works well with ES5 shim upfront in IE8 (and maybe lower too).
Live test