@ungap/essential-weakset

Essential WeakSet for legacy browsers.

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
@ungap/essential-weakset
300.2.12 years ago4 years agoMinified + gzip package size for @ungap/essential-weakset in KB

Readme

WeakSet
Build Status Coverage Status Greenkeeper badge WebReflection status
An essential WeakSet poorlyfill legacy browsers that don't have even a WeakMap but need just a WeakSet.
CDN via https://unpkg.com/@ungap/essential-weakset ESM via import WeakSet from '@ungap/essential-weakset' CJS via const WeakSet = require('@ungap/essential-weakset')
Compatible down to IE9, works well with ES5 shim upfront in IE8 (and maybe lower too).
Live test