asset-require-hook

A require hook for importing asset files during runtime

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
asset-require-hook
1.2.05 years ago7 years agoMinified + gzip package size for asset-require-hook in KB

Readme

asset-require-hook
A require hook for importing asset files during runtime.

Features

Allows files required by node that match a given set of extensions to be returned as either a data URI, or a custom filename. Meant to be used in conjunction with file-loader or url-loader when building universal apps.

Requirements

Using this tool requires Node.js v0.12.x or higher.

Installation

$ npm i --save asset-require-hook

Usage

Attach the require hook to the desired file extensions using the extensions parameter.
require('asset-require-hook')({
  extensions: ['jpg']
})

// const image = require('./icon.jpg');

The require hook accepts the same parameters as the file-loader.
require('asset-require-hook')({
  extensions: ['jpg'],
  name: '[hash].[ext]'
})

To enable data URI's use the limit parameter, and optionally any other parameters used by the url-loader.
require('asset-require-hook')({
  extensions: ['woff'],
  mimetype: 'application/font-woff',
  limit: 10000
})