babel-plugin-version

babel plugin replace define Identifier / StringLiteral `__VERSION__` to pkg.version!

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
babel-plugin-version
0.2.34 years ago4 years agoMinified + gzip package size for babel-plugin-version in KB

Readme

babel-plugin-version
A babel plugin replace define Identifier / StringLiteral to pkg.version!
npm npm

Install

npm i --save-dev babel-plugin-version

Usage

Add it into .babelrc.
{
  "plugins": [
    "version"
  ]
}

Result

- Input
const a = { a: __VERSION__ };

const b = a === __VERSION__;

const c = [__VERSION__];

const d =__VERSION__ = 1;

const e = "__VERSION__";

- Output
const a = { a: "0.1.0" };

const b = a === "0.1.0";

const c = ["0.1.0"];

const d = __VERSION__ = 1;

const e = "0.1.0";

Configure

You can customize the default __VERSION__ define.
{
  "plugins": [
    ["version", {
      "define": "__PKG_VERSION__",
      "identifier": false,
      "stringLiteral": true 
     }]
  ]
}

Test

npm i

npm t

Then see the files in lib dir.

License

MIT