babel-preset-es2015-node

Babel preset for all es2015 plugins needed with latest stable node.

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
babel-preset-es2015-node
8926.1.18 years ago9 years agoMinified + gzip package size for babel-preset-es2015-node in KB

Readme

babel-preset-es2015-node
!npm versionnpm-badgenpm-href
Babel preset for the minimum necessary babel-preset-es2015 plugins needed for your version of node

This preset automatically determines which version of node you are using via process.version and sets the minimum necessary babel-preset-es2015 plugins accordingly.
All versions of node ≥4 are supported.
Note: the major version of this package corresponds to the compatible major version of Babel (i.e. use babel-preset-es2015-node@6 with babel-cli@6.

Install

$ npm install --save-dev babel-preset-es2015-node

Usage

Via .babelrc (Recommended)

.babelrc
{
  "presets": ["es2015-node"]
}

Via CLI

$ babel script.js --preset es2015-node

Via Node API

require("babel-core").transform("code", {
  presets: ["es2015-node"]
});