babel-preset-es2040

Babel preset for a subset of ES6

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
babel-preset-es2040
1.1.16 years ago6 years agoMinified + gzip package size for babel-preset-es2040 in KB

Readme

babel-preset-es2040
!npm version23 !downloads89 !js-standard-style1011
Babel preset for a subset of ES6, because in hindsight we can do without most of it

Install

$ npm install --save-dev babel-preset-es2040

Usage

Via .babelrc (Recommended)

.babelrc
{
  "presets": ["es2040"]
}

Via CLI

$ babel script.js --presets es2040

Via Node API

require('babel-core').transform('code', {
  presets: ['es2040']
})

See Also

  • es2040 - browserify transform for a
subset of ES6 babel preset for more minimal subset

License

MIT