enb-require-or-eval

Module, which assists in supporting transitional (from 'eval' to 'require') BEM formats.

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
enb-require-or-eval
001.0.27 years ago7 years agoMinified + gzip package size for enb-require-or-eval in KB

Readme

enb-require-or-eval
Build Status Build status
Module, which assists in supporting transitional (from 'eval' to 'require') BEM formats.
Usage:
var requireOrEval = require('enb-require-or-eval');

function someEvalingFunc() {
	return requireOrEval('path/to/bemjson.js').then(function (result) {
		//process result here
	}
}