eslint-plugin-react-native-i18n

ESLint plugin for React Native + i18n

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
eslint-plugin-react-native-i18n
0.0.62 years ago5 years agoMinified + gzip package size for eslint-plugin-react-native-i18n in KB

Readme

eslint-plugin-react-native-i18n
ESLint plugin for React Native and i18n

Installation

You'll first need to install ESLint:
$ npm i eslint --save-dev

Next, install eslint-plugin-react-native-i18n:
$ npm install eslint-plugin-react-native-i18n --save-dev

Note: If you installed ESLint globally (using the -g flag) then you must also install eslint-plugin-react-native-i18n globally.

Usage

Add react-native-i18n to the plugins section of your .eslintrc configuration file. You can omit the eslint-plugin- prefix:
{
    "plugins": [
        "react-native-i18n"
    ]
}

Then configure the rules you want to use under the rules section.
{
    "rules": {
        "react-native-i18n/no-unknown-key": "error"
    }
}

Then add the required settings under the sessions section.
{
    "settings": {
        "i18n": {
            "allowEmpty": true,
            "languages": {
                "en": "i18n/en.js",
                "nl": "i18n/nl.json",
            }
        }
    }
}

Note that using .js language files is supported but you can't use ES6's export default { .. }. Use module.export = { .. } instead.