eslint-plugin-xo

ESLint rules for XO

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
eslint-plugin-xo
2,9713141.0.06 years ago7 years agoMinified + gzip package size for eslint-plugin-xo in KB

Readme

eslint-plugin-xo Build Status Coverage Status
ESLint rules for XO

This plugin is bundled with XO, but can still be useful if you don't use XO.

Install

$ npm install --save-dev eslint eslint-plugin-xo

Usage

Configure it in package.json.
{
	"name": "my-awesome-project",
	"eslintConfig": {
		"env": {
			"es6": true
		},
		"parserOptions": {
			"ecmaVersion": 7,
			"sourceType": "module"
		},
		"plugins": [
			"xo"
		],
		"rules": {
			"xo/catch-error-name": ["error", {"name": "err"}],
			"xo/explicit-length-check": "error",
			"xo/filename-case": ["error", {"case": "kebabCase"}],
			"xo/no-abusive-eslint-disable": "error",
			"xo/no-process-exit": "error",
			"xo/throw-new-error": "error"
		}
	}
}

Rules

Recommended config

This plugin exports a recommended config that enforces good practices.
Enable it in your package.json with the extends option:
{
	"name": "my-awesome-project",
	"eslintConfig": {
		"plugins": [
			"xo"
		],
		"extends": "plugin:xo/recommended"
	}
}

See the ESLint docs for more information about extending config files.
Note: This config will also enable the correct parser options and environment.

Created by

License

MIT © Sindre Sorhus