gint

A pluggable and configurable GIT linter tool

  • gint

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
gint
0.9.24 years ago5 years agoMinified + gzip package size for gint in KB

Readme

gint npm version Build Status
A pluggable and configurable GIT linter tool

Gint can help with enforcing commit message patterns, branch sizes and heaps more.

Install

npm i gint --only=dev

Existing hooks aren't replaced

Uninstall

npm uninstall gint

Usage

Gint requires you to create a configuration file named .gintrc in your project root. See example below.
{
  "rules": {
    "commit-message-pattern": ["error", "^\\[(patch|minor|major)\\]\\s.{3,}", "i"],
    "commit-min-len": ["error", 10],
    "commit-max-len": ["error", 512]
  }
}

Rules

Refer to rules documentation.

Git GUI clients support

If you've installed Node using the standard installer, nvm or homebrew, Git hooks will be executed in GUI applications.

Working with multiple version of Node

If nvm is installed, gint will try to use the default/current installed Node version or use the project .nvmrc.
Tip to use the system-installed version of node, nvm provides a system alias

See also

  • Husky - Heavily based on husky source code.

License

MIT