gulp-babel-deps

Gulp plugin that compiles javascript files and all their dependencies with babel

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
gulp-babel-deps
102.0.17 years ago8 years agoMinified + gzip package size for gulp-babel-deps in KB

Readme

gulp-babel-deps
Gulp plugin for babel-deps.

Usage

var gulp = require('gulp');
var babelDeps = require('gulp-babel-deps');

gulp.task('build', function() {
  gulp.src('src/*.js')
    .pipe(babelDeps())
    .pipe(gulp.dest('build'));
});

API

options

The options that gulp-babel-deps receives are the same ones accepted by babel-deps.