gulp-yaml-validate

Gulp plugin for validating yaml files

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
gulp-yaml-validate
1.0.29 years ago9 years agoMinified + gzip package size for gulp-yaml-validate in KB

Readme

gulp-yaml-validate

Install

npm install --save-dev gulp-yaml-validate

Usage

var yaml = require('gulp-yaml-validate');

gulp.src('./src/*.yml')
  .pipe(yaml());

gulp.src('./src/*.yml')
  .pipe(yaml({ safe: true }));

gulp.src('./src/*.yml')
  .pipe(yaml({ html: true }));

API

yaml(options)

options.safe

Type: Boolean
Default: false
Enable or disable support for regexps, functions and undefined.
This flag should be enabled when working with untrusted data.

options.space

Type: Number or String
Default: null
Control spacing in the resulting output. It has the same usage as for JSON.stringify

options.replacer

Type: Function or Array
Default: null
Further transform the resulting output. It has the same usage as for JSON.stringify

options.safe

Type: Boolean
Default: false
Enable or disable support for html tags in yaml strings.
This flag should be enabled when working with untrusted data.

License

MIT ©