is-safe-integer

ES2015 Number.isSafeInteger() ponyfill

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
is-safe-integer
2.0.05 years ago9 years agoMinified + gzip package size for is-safe-integer in KB

Readme

Deprecated
This package is no longer relevant as ES2015 support is widespread.
is-safe-integer Build Status
ES2015 Number.isSafeInteger() ponyfill

Install

$ npm install --save is-safe-integer

Usage

var isSafeInteger = require('is-safe-integer');

isSafeInteger(3);
//=> true

isSafeInteger(100719925474099143523412);
//=> false

isSafeInteger(Infinity);
//=> false

Related

License

MIT © Sindre Sorhus