karma-backbone-chai

A karma plugin adapter for newest chai-backbone

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
karma-backbone-chai
0.1.16 years ago6 years agoMinified + gzip package size for karma-backbone-chai in KB

Readme

karma-backbone-chai
A karma plugin adapter for newest chai-backbone

Requirements

This plugin requires Karma ~0.10 and the karma-sinon-chai plugin ~0.1.

Installation

Install as npm module
$ npm install karma-sinon-chai karma-backbone-chai --save-dev

Add sinon-chai and chai-backbone to the frameworks in your Karma configuration (order is important):
module.exports = function(config) {
  config.set({
    frameworks: ['mocha', 'sinon-chai', 'backbone-chai'],
  });
}

Usage

See chai-backbone for more information on the chai-backbone extension.