pa11y-runner-axe

An aXe runner for Pa11y

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
pa11y-runner-axe
702.0.12 years ago6 years agoMinified + gzip package size for pa11y-runner-axe in KB

Readme

Pa11y aXe Runner
⚠️ This package is now bundled with pa11y. You can find the latest version in the pa11y repo. ⚠️
An aXe runner for Pa11y.
!NPM versionshield-npminfo-npm !Build statusshield-buildinfo-build !LGPL-3.0 licensedshield-licenseinfo-license

Table of contents

Compatibility chart

Requirements

The Pa11y aXe runner is compatible with Pa11y 5 and later versions. It will not work with older versions of Pa11y.

Compatibility chart

| Pa11y version | Pa11y aXe runner version | |---------------|----------------------------| | 1.x - 4.x | Unsupported | | 5.x | 1.x | | 6.x | 2.x |

Usage

Install Pa11y and the Pa11y aXe runner with npm (locally or globally is fine):
npm install -g pa11y pa11y-runner-axe

Run Pa11y using the aXe runner:
pa11y --runner axe http://example.com

Contributing

There are many ways to contribute to the Pa11y aXe runner, we cover these in the contributing guide for this repo.
If you're ready to contribute some code, clone this repo locally and commit your code on a new branch.
Please write unit tests for your code, and check that everything works by running the following before opening a Pull Request:
make ci

You can also run verifications and tests individually:
make verify              # Verify all of the code (ESLint)
make test                # Run all tests
make test-unit           # Run the unit tests
make test-unit-coverage  # Run the unit tests with coverage

License

The Pa11y aXe runner is licensed under the Lesser General Public License (LGPL-3.0)info-license.
Copyright © 2018, Team Pa11y