parse-shim

Requires the right version of Parse JS SDK for a particular platform

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
parse-shim
711.0.76 years ago8 years agoMinified + gzip package size for parse-shim in KB

Readme

parse-shim
Requires the right version of Parse JS SDK for a particular platform.

Raison d'√Čtat

Versions of the Parse JS SDK >=1.6.0 split the codebase into two requireables:
- The version of parse for the browser require('parse') - The version of parse for node require('parse/node')
If you share code between a front-end and back-end you will find the need to load one version of Parse when in the browser environment but another if you are in the Node environment. This module will come in handy.

Installation

npm install --save parse-shim

Usage

var Parse = require('parse-shim'); // works in browser or Node.JS environment