samlify-q

High-level API for Single Sign On (SAML 2.0)

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
samlify-q
002.4.16 years ago6 years agoMinified + gzip package size for samlify-q in KB

Readme

samlify ยท Build Status npm version Coverage Status
Highly configuarable Node.js SAML 2.0 library for Single Sign On

Welcome PRs

Welcome all PRs for maintaining this project, or provide a link to the repositories especially for use cases alongside with different frameworks.

Sponsor

| |
If you want to quickly implement SAML SSO, feel free to check out Auth0's NodeJS SDK and free plan at auth0.com/overview.
| |:-------------------------:|:-------------------------|

Installation

To install the stable version
$ yarn add samlify

Development

This project is now developed using TypeScript, also support Yarn which is a new package manager.
$ yarn global add typescript
$ yarn

Get Started

const saml = require('samlify');
See full documentation here

Example

react-samlify SP example powered by React, TypeScript and Webpack

Talks

An introduction to Single Sign On

License

MIT

Copyright

Copyright (C) 2016-present Tony Ngan, released under the MIT License.