vue-pug-lint-loader

Vue pug linter for webpack

Downloads in past

Stats

StarsIssuesVersionUpdatedCreatedSize
vue-pug-lint-loader
500.0.22 years ago5 years agoMinified + gzip package size for vue-pug-lint-loader in KB

Readme

vue-pug-lint-loader
Vue pug lint loader for webpack

Install

$ npm install vue-pug-lint-loader --save-dev

Usage

In your webpack configuration
module.exports = {
  // ...
  module: {
    rules: [
      {
        test: /\.vue$/,
        exclude: /node_modules/,
        loader: "vue-pug-lint-loader",
        options: require('./.pug-lintrc.js'),
        enforce: "pre"
      },
    ],
  },
  // ...
}

To be safe, you should use enforce: "pre" section to check source files, not modified by other loaders (like pug-loader)

Options

You can pass puglint options using standard webpack loader options.

License

MIT License